Schlagwort-Archive: sighax

SafeB9SInstaller v0.0.6

d0k3 hat seinen Installer für boot9strap aktualisiert.

DOWNLOAD

Es gibt neue Einstiegspunkte, u.a. für die Firmware 2.1 und der Installer kann jetzt von boot9strap aufgerufen werden (mit der .FIRM-Datei), wobei er dann als Updater fungiert. Boot9strap lässt sich nun auf Konsolen installieren, die 3DSafe installiert haben (es wird dabei entfernt) und die secret_sector.bin wird nicht mehr auf dem Old3DS mit installiertem arm9loaderhax benötigt.

Wie immer gilt: Bitte 3ds.guide lesen, wenn ihr euren 3DS modden wollt! Dort ist auch beschrieben, wie ihr von arm9loaderhax auf boot9strap aktualisiert.

* New 2xrsa, Launcher.dat and .firm entrypoints
* Installation is now also handled on 3Dsafe'd consoles
* secret_sector.bin no more required on A9LH O3DS consoles
* Improved emergency routines (as if anyone will ever see them)

GodMode9 v1.1.8, Luma3DS v7.1 und Luma3DS Updater v2.0 mit Sighax-Unterstützung

Hier kommen gerade einige Updates rein, also lasst uns diese nach und nach abarbeiten!

Godode9d0k3 hat GodMode9 auf v1.1.8 aktualisiert.

DOWNLOAD

GodMode9 lässt sich jetzt per boot9strap/sighax ausführen, eine GodMode9.firm ist dazu enthalten (anstatt GodMode9.bin für arm9loaderhax). Per boot9strap lassen sich der boot9, boot11 und die OTP dumpen – und das ganz ohne Downgrade! Eine neue Suche für installierte Titel wurde hinzugefügt, wenn R+A auf den Title-Verzeichnissen gedrückt wird und ein CXI-Dumper kann gestartet werden, wenn "A" auf einer TMD gedrückt wird. NCCH, NCSD, CIA und NDS lassen sich nun umbenennen und der obere und untere Bildschirm wurden getauscht.


Luma3DSAuroraWright hat Luma3DS für Sighax fit gemacht.

DOWNLOAD

Boot9strap/sighax wird jetzt unterstützt – alle anderen Einstiegspunkte, wie arm9loaderhax, werden nicht mehr unterstützt! Payloads müssen jetzt auch im FIRM-Format vorliegen. LayeredFS bekam einige Fixes und wenn nur ein einziger Payload vorhanden ist, wird dieser gestartet, wenn "START" gedrückt gehalten wird.


ARNUpdateKunoichiZ hat den Luma3DS Updater geforkt.

DOWNLOAD

Ihr habt’s erkannt: boot9strap/sighax wird jetzt unterstützt. Ältere Versionen funktionieren nicht mehr, da Luma3DS arm9loaderhax nicht mehr unterstützt.

Sighax: Nintendo 3DS Bootrom-Exploit veröffentlicht

Hedge, SciresM und derrek haben sighax veröffentlicht. Derreks Implementation trägt dabei den Namen "Sighax", die Community-Implementation den Namen "boot9strap" und liest einen Payload von der SD-Karte.. Das ist quasi die letzte Hürde in Sachen 3DS-Homebrew!

NICHT DEN INSTALLER VON SIGHAX.COM VERWENDEN, DA DIESER DEN 3DS BRICKT!

ZUM 3DS-GUIDE ->

Sighax ist ein Exploit, der einen Fehler in der ARM9-Bootrom ausnutzt, um invalide Signaturen für fremde Firmware als valide erscheinen zu lassen. Das heißt, dass der 3DS dann eine modifizierte Firmware bootet, die nicht von Nintendo stammt, aber die Konsole selbst “denkt”, dass dies so wäre. Normalerweise wird eine modifizierte Firmware abgelehnt, wenn der Header der Firmware-Partition im NAND geändert wird. Sighax erlaubt es jedoch, jeden modifizierten Firmware-Header valide zu machen und so kann eigener Code von den Firmware-Partitionen im NAND ausgeführt werden. Wir empfehlen unseren Beitrag "Was ist Sighax?" für eine volle Übersicht.

Kurz gesagt: Sighax ist quasi eine verbesserte Alternative zu arm9loaderhax. Bei boot9strap handelt es sich um eine Variante des Luma3DS-Chainloader von SciresM – um Verwirrungen vorzubeugen, bezeichnen wir anfangs diese immer als "sighax/boot9strap", wobei "boot9strap" die korrekte Bezeichnung ist.

Boot9strap wird per SafeB9SInstaller installiert. Nicht vergessen, dass dieser auch per Hardmod auf 11.4 installiert werden kann – oder per DSiWare, wenn ihr bereits eins der folgenden DSiWare-Spiele früher heruntergeladen habt: Legends of Exidia, Fieldrunners, Guitar Rock Tour, Zelda: Four Swords Adventures.

Ihr könnt auch von arm9loaderhax auf boot9strap upgraden – Instruktionen findet ihr wie immer auf 3ds.guide. Wir empfehlen das Upgrade von arm9loaderhax auf boot9strap, da z.B. Luma3DS in der aktuellen Version A9LH nicht mehr unterstützt.